Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одн...
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет. Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO
Уровень C. Задача O. Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет. Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO
Ответ(ы) на вопрос:
Гость
Program n1;
var a, b, c, s: longint;
begin
read(c);
repeat
a := c mod 10;
c := c div 10;
s := c;
while s > 0 do
begin
b := s mod 10;
s := s div 10;
if (a = b) then begin
writeln('yes');
a :=77;
break;
end;
end;
if (a = 77) then break
until (c = 0);
if (a <> 77) then
writeln('no');
end.
Не нашли ответ?
Похожие вопросы