В одномерном массиве найти среднее арифметическое элементов массива(написать программу на паскале) Помогите пожалуйстаа
В одномерном массиве найти среднее арифметическое элементов массива(написать программу на паскале)
Помогите пожалуйстаа
Ответ(ы) на вопрос:
Гость
Const N = 50;
Var
A:array[1..N] of integer;
i:integer;
S:real;
Begin
Randomize;
Write('Исходный массив: ');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ');
S:=S+A[i]
End;
WriteLn;
WriteLn('Sr = ',S/N);
End.
Пример:
Исходный массив: 4 2 -2 -4 -7 7 -9 6 -10 10 -4 -4 -5 3 0 -2 -3 0 -4 9 -1 -4 -2 -4 -9 2 2 -10 -8 -2 -8 -7 6 2 -9 7 2 -10 -10 -4 -9 -7 -2 -10 2 1 -3 6 0 0
Sr = -2.04
Не нашли ответ?
Похожие вопросы