В ПАСКАЛЬ АБС. В ЭВМ поступают результаты соревнований по плаванию для трех спортсменов. Составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.
В ПАСКАЛЬ АБС. В ЭВМ поступают результаты соревнований по плаванию для трех спортсменов. Составьте программу, которая выбирает лучшей результат и выводит его на экран с сообщением, что это лучшей результат.
Ответ(ы) на вопрос:
var i :integer; a, b:real; begin for i:=1 to 3 do begin write ('a='); readln(a); if (a>b) then b:=a; end; writeln ('a=' , b); end.
const
N = 3; var
a: array[1..N] of integer;
i, max: integer; begin
max := 0;
writeln('Введите результаты трех спортсменов');
for i := 1 to N do readln(a[i]);
for i := 1 to N do
begin
if a[i] > max then
max := a[i];
end;
writeln;
writeln('Лучший результат среди трех спортсменов - ', max);
end.
Не нашли ответ?
Похожие вопросы