Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a меньше =b, a...
Вопрос №591394 (тип: C)
Даны два целых числа a и b.
Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b
Входные данные:
В первой строке вводятся два целых числа a и b (a<=b, a,b не больше 100 по модулю)
Выходные данные:
Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой)
Ответ(ы) на вопрос:
Гость
Program n1;
var a,b,i: integer;
sum,k: real;
begin
sum:=0;
k:=0;
readln(a,b);
for i:=a to b do
begin
sum:=sum+i*i;
k:=k+1;
end;
writeln(sum/k:6:2);
end.
Гость
#include
using namespace std;
int main() {
int a, b;
cin >> a >> b;
int sum = 0;
for (int i = a; i <= b; i++)
sum += i * i;
cout.precision(2);
cout << fixed << (float) sum / (b - a + 1);
return 0;
}
Не нашли ответ?
Похожие вопросы