Вопрос по С++ Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4-8 символов) слов во всех строках текста То что придумал #include "stdafx.h" #include #include #include #include u...

Вопрос по С++ Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4-8 символов) слов во всех строках текста То что придумал #include "stdafx.h" #include #include #include #include using namespace std; int main(int argc, _TCHAR* argv[]) { FILE *text; char *filename = "C:\\Myfile.txt"; char buf[101] = ""; char commentStr[101] = ""; if (!(fopen_s(&text, filename, "r"))) { while (fgets(buf, 100 , text)) printf_s("%s", buf); char* pmin = NULL; size_t pminlen = 0; char* head; char* tail; while (*tail) { for (head = tail; *head && !isalnum(*head); ++head) { ; } for (tail = head; *tail && isalnum(*tail); ++tail) { ; } if (head < tail) { if ((pmin == NULL) || (pminlen > tail - head)); { pmin = head; pminlen = tail - head; } } } if (pmin) { printf("\n"); printf("min = %.*s\n", pminlen, pmin); } system("pause"); return 0; } ничего не выдает в чем ошибка ( как мне кажется их тут дофига)
Гость
Ответ(ы) на вопрос:
Гость
Не люблю сишные приколы, даже не стал ковырять в коде. Я бы так написал: 1. Листинг программы: #include #include #include using namespace std; int main() { ifstream f("words.txt"); int MAX_WORD = 6; if(!f.is_open()) { cout <<"Ошибка открытия файла!" <
Не нашли ответ?
Ответить на вопрос
Похожие вопросы