Язык -  Pascal. даны натуральное число n и последовательностьa1, ...., an. Составьте программу,которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9

Язык -  Pascal. даны натуральное число n и последовательностьa1, ...., an. Составьте программу,которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9
Гость
Ответ(ы) на вопрос:
Гость
var  n, i, s, a, k: integer; begin readln(n); s := 0; k := 0; for i := 1 to n do begin read(a); if (a mod 3 = 0) and (a mod 9 <> 0) then begin inc(k); inc(s, a); end; end; write(s div k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы