Задача 1. Составить программу, которая запрашивает у пользователя два числа (m, n), находит их сумму (S) и произведение (P). Сравнивает значения суммы и произведения и выводит сообщение какое больше (сумма или произведение) и н...
Задача 1. Составить программу, которая запрашивает у пользователя
два числа (m, n), находит их сумму (S) и произведение (P). Сравнивает значения суммы
и произведения и выводит сообщение какое больше (сумма или произведение) и на
сколько.
Иногда в задачах требуется выполнение не одного, а нескольких условий или
одного из нескольких. Тогда простые условия образуют составные при помощи логических
операций and или or.
Формат записи
составного условия:
(условие 1) and (условие
2) and…and (условие
N)
(условие 1) or (условие
2) or…or (условие N)
Задача 2. В школу
танцев принимаются учащиеся не выше 178 см и не ниже 168 см. Написать программу,
которая определяет, будете ли Вы приняты в школу танцев.
Условие:
if (rost<178) and (rost>168) then write (‘Приняты!‘) else write (‘ Не приняты!‘);
Задача 3. Составить
программу, которая определяет, является ли данное число трехзначным и выводит
сообщение об этом (двузначным является число от 10 до 99).
Задача 4. На работу в компанию принимаются люди не старше 42 лет и
имеющие стаж работы не менее 5 лет. Написать программу, которая определяет,
будет кандидат принят на работу или нет.
Задача 5. Дано некоторое число b. Составить программу, которая удваивает данное число если оно,
принадлежит интервалу [m;n], ыв противном случае
заменяет его на противоположное.
PS: pascal(не турбо),всем буду благодарен!
Ответ(ы) на вопрос:
Задание 2
Program ada4a2;
Var rost:Integer;
Begin
WriteLn('Введите ваш возраст: ');
Read(rost);
If (rost<178) and (rost>168) Then Write('Приняты')
Else Write('Не приняты');
ReadLn;
End.
Не нашли ответ?
Похожие вопросы