Задача 4. Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы: for i:=1 to 100 do for k:=1 to 100 do if i больше k then A[i,k] := 1 else A[i,k] := -1; Чему равна сумма ...
Задача 4. Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:
for i:=1 to 100 do
for k:=1 to 100 do
if i > k then
A[i,k] := 1
else A[i,k] := -1;
Чему равна сумма элементов массива после выполнения этого фрагмента программы?
1) 0 2) 100 3) -100 4) -200
Ответ(ы) на вопрос:
Составим программку:
uses Crt;
const n=20;
type Mas=array [1..n, 1..n] of integer;
var A: Mas;
i,k, Sum: integer;
begin
ClrScr;
Sum:=0;
for i:=1 to n do
begin
for k:=1 to n do
begin
if i>k then
begin
A[i,k]:=1;
Sum:=Sum+A[i,k];
end
else
begin
A[i,k] :=-1;
Sum:=Sum+A[i,k];
end;
Write(A[i,k]:3);
end;
WriteLn;
end;
WriteLn;
WriteLn(' Sum = ',Sum);
ReadLn;
end.
Эта программа симметрично относительно главной диагонали заполняет массив единичками с плюсом или минусом и считает сумму диагональных элементов.
Если n=20, то Sum = -20
Если n = 100, то Sum = - 100
ПРАВИЛЬНЫЙ ОТВЕТ: 3) - 100
Фрагмент программы инициализирует матрицу размером 100х100.
При этом, значения элементов, лежащих выше главной диагонали, равны 1, а значения остальных элементов равны -1.
При суммировании всех элементов матрицы элементы, лежащие выше главной диагонали и элементы, лежащие ниже нёё, в сумме дадут ноль. Следовательно, общая сумма будет равна сумме элементов, лежащих на главной диагонали. Таких элементов 100, их значение равны -1, и значение суммы будет равно 100х(-1)=-100.
Ответ: 3) -100
Не нашли ответ?
Похожие вопросы