Задача на c++ Дано трехзначное число. Напишите программу определения, является ли оно палиндромом, т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Формат входных данных Вводятся одно це...
Задача на c++
Дано трехзначное число. Напишите программу определения, является ли оно палиндромом, т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
Формат входных данных
Вводятся одно целое число aa (100≤a≤999)
Формат выходных данных
Требуется вывести «YES», если число является палиндромом, и «NO» в противном случае.
Ответ(ы) на вопрос:
#include
using namespace std;
int main() {
int n;
cin >> n;
if (n/100 == n%10)
cout << "YES\n";
else cout << "NO\n";
return 0;
}
Пример:
323
YES
Не нашли ответ?
Похожие вопросы