Задача: Составить программу расчёта числа загонов (шт.) на пастбище по формуле: К=П/Д+З, где П-период, необходимый для отрастания травы на пастбище, дн.; Д- количество дней пастьбы для скота в каждом загоне, дн.; З- потребное к...

Задача: Составить программу расчёта числа загонов (шт.) на пастбище по формуле: К=П/Д+З, где П-период, необходимый для отрастания травы на пастбище, дн.; Д- количество дней пастьбы для скота в каждом загоне, дн.; З- потребное количество загонов для возобновления травостоя, шт.; Количество дней пастьбы  скота изменяется в пределах от 1 до 5 дней с шагом 1 день.
Гость
Ответ(ы) на вопрос:
Гость
program qq; uses crt; var p, d, z, i: integer; k:real; begin writeln('Введите период для отрастания травы в днях:'); readln(p); writeln('Введите потребное количество загонов:'); readln(z); for i:=1 to 5 do     begin     d:=i; // переменная дней изменяется, как дано в условии от 1 до 5 дней     k:=round(p/d+z); //процедура round округляет по всем правилам число загонов. Ведь весьма нелогично строить, например 3,3333 загона:)     writeln ('Для количества дней пастьбы - ', d,' требуется загонов - ',k);     end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы