Задачи по Паскалю.Условный оператор.1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.2.Найдите решение уравнения ах+ в=0, если оно существует,если а=03.написать программу удвоени...

Задачи по Паскалю.Условный оператор. 1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0 3.написать программу удвоения меньшего из двух чисел
Гость
Ответ(ы) на вопрос:
Гость
1) program chik2; var a,b,c:real; begin readln(a,b); if(a=b)then begin c:=b; b:=(a+b)/2; a:=a*c; end; writeln(a,' ',b); end. 2) program chik; var a,x,b:real; begin readln(a,b); if(a=0)and(b<>0)then writeln('НЕТ решений'); if(a<>0)then begin  x:=-b/a; writeln(x); end; end. 3) program chik3; var a,b:real; begin readln(a,b); if(a
Не нашли ответ?
Ответить на вопрос
Похожие вопросы