Задан массив из 10 целых чисел. Написать программу которая находт -сумму всех элементов массива -колличество чётных и нечётных элементов массива
Задан массив из 10 целых чисел. Написать программу которая находт
-сумму всех элементов массива
-колличество чётных и нечётных элементов массива
Ответ(ы) на вопрос:
const n=10;
var a:array[1..n] of integer;
i,s,k1,k2:integer;
begin
writeln('vvedite massiv=');
for i:= 1 to n do
readln(a[i]);
s:=0;
k1:=0;
k2:=0;
for i:= 1 to n do
begin
s:=s+a[i];
if a[i] mod 2=0 then inc(k1) else inc(k2);
end;
writeln('s=',s,' k1=',k1,' k2=',k2);
readln;
end.
Не нашли ответ?
Похожие вопросы