Задана гипотенуза прямоугольного треугольника и длина одного из катетов. составьте программу, с помощью которой определите периметр и площадь этого треугольника. Помогите пожалуйста((

Задана гипотенуза прямоугольного треугольника и длина одного из катетов. составьте программу, с помощью которой определите периметр и площадь этого треугольника. Помогите пожалуйста((
Гость
Ответ(ы) на вопрос:
Гость
Написали бы язык программирования хотя бы. Вот вам на java ^_^ import java.io.BufferedReader; import java.io.InputStreamReader; public class prog{  public static void main(String[] args) throws Exception{  BufferedReader reader=new BufferedReader(new  InputStreamReader(System.in));  System.out.println("Введите гипотенузу:");  int c=Integer.parseInt(reader.readLine());  System.out.println("Введите длину катета:");  int a=Integer.parseInt(reader.readLine());  double b=Math.sqrt(c*c-a*a);  double P=a+b+c;  System.out.println("Периметр: "+P);  double S=(a*b)/2;  System.out.println("Площадь: "+S); } }
Гость
Рисунок элементарный: прямоугольный ΔАВС, угол С-прямой. Гипотенуза АВ=АС+2, значит АС=АВ-2 Периметр Р=40 АВ+ВС+АС=40 АВ+ВС+АВ-2=40 2АВ+ВС=42 ВС=42-2АВ По т.Пифагора АВ²=АС²+ВС² АВ²=(АВ-2)²+(42-2АВ)² АВ²=АВ²-4АВ+4+1764-168АВ+4АВ² 4АВ²-172АВ+1768=0 АВ²-43АВ+442=0 D=1849-1768=81=9² АВ₁=(43-9)/2=17 АВ₂=(43+9)/2=26 (не сответствует, т.к. Р=40) АВ=17, АС=17-2=15, ВС=42-2*17=8
Не нашли ответ?
Ответить на вопрос
Похожие вопросы