Задание: написать программу, вычисляющую произведение элементов одномерного массива Z(N). Рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение P:=P*Z[k] перед циклическим процессом нужн...
Задание: написать программу, вычисляющую произведение элементов одномерного массива Z(N).
Рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение P:=P*Z[k] перед циклическим процессом нужно задать как 1, т.е. P:=1;
Ввод и вывод массива выполните через текстовый файл.
Ответ(ы) на вопрос:
Var Z:array[1..100] as integer; P:integer; i,n:integer; begin Reset(input,'input.txt'); Rewrite(output,'output.tx); readln(n); For i:=1 to n do Readln(Z[i]); P:=1; For i:=1 to n do P:=p*z[i]; Writeln(p); Close(input); Close(output); end.
Не нашли ответ?
Похожие вопросы