Задание по ИКТ!! Составить программу с пояснениями!! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их сумму. В паскале а если еще можно то блок схему)

Задание по ИКТ!! Составить программу с пояснениями!! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их сумму. В паскале а если еще можно то блок схему)
Гость
Ответ(ы) на вопрос:
Гость
Program mas; const n=4; // число элементов var a: array [1..n] of integer; //массив i, sum: integer; //переменные begin //начало sum:=0; // сумма=0 for i:=1 to n do readln(a[i]); //вводим массив for i:=1 to n do //цикл if(a[i] mod 2 <>0) then //условие нечетности begin writeln(a[i]); //выводим нечетные sum:=sum+a[i]; //считаем сумму end; writeln(sum); //выводим сумму end. //конец
Не нашли ответ?
Ответить на вопрос
Похожие вопросы