Заполнить массив (А) случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному. Очень надо. Пожалуйста!!!!

Заполнить массив (А) случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному. Очень надо. Пожалуйста!!!!
Гость
Ответ(ы) на вопрос:
Гость
const n=10; var a:array[1..n] of integer; max,i:integer; begin Randomize; writeln('Исходный массив:'); for i:=1 to n do begin  a[i]:=random(21)-10;  write(a[i],' ');  end; writeln; max:=a[1]; for i:=2 to n do  if a[i]>max then max:=a[i]; writeln('max = ',max); for i:=1 to n do  if a[i]=max then write(i:3); writeln; end. Пример: Исходный массив: -6 -9 10 -6 0 0 -8 10 -8 2  max = 10   3  8
Не нашли ответ?
Ответить на вопрос
Похожие вопросы