Заполните массив С (30) случайными числами от 0 до 55 и распечатайте его Найдите сумму элементов данного массива, больших 15 3.найдите максимальный элемент данного массива 4.Отсортируйте массив С (300 по убыванию методом «пузыр...
Заполните массив С (30) случайными числами от 0 до 55 и распечатайте его
Найдите сумму элементов данного массива, больших 15
3.найдите максимальный элемент данного массива
4.Отсортируйте массив С (300 по убыванию методом «пузырька»
Ответ(ы) на вопрос:
Гость
для "Заполните массив С (30) случайными числами от 0 до 55 и распечатайте его
Найдите сумму элементов данного массива, больших 15"
var x: array[0..30] of integer;
i,sum:integer;
begin
randomize;
for i:=0 to 30 do
begin
x[i]:=random(56);
writeln(x[i]);
if x[i]>15 then sum:=sum+x[i];
end;
writeln('сумма чисел больше 15 = '+sum);
end.
Гость
program t1;var i, j: integer; mas: array [1..10] of integer;begin randomize; writeln ('сгенерированный масив: '); for i := 1 to 10 do begin mas[i] := random (100) - 50; write (mas[i]); end;
begin for j:=1 to 9 do for i:=1 to 9-j do if M[i] < M[i+1] then swap(mas[i],mas[i+1]) end; writeln for i := 1 to 10 do write (mas[i]);end;end. program z1; uses crt; var i, n:integer; a:array[1..10000] of integer;begin clrscr; randomize; write(' размер =' );readln(n); for i:=1 to n do begin a[i]:=random(46))+1;
write(a[i], ' ' ); end;
for i:=n downto 1 do write(a[i],' '); readkey;end.program z2; uses crt; var i, n, r: integer; a: array[1.. 10000] of integer;begin clrscr; randomize; write readln(n); for i:=1 to n do begin a[i]:=random(45)-22; write(a[i],' '); end; i:=1; while i<=n-1 do begin r:=a[i];a[i]:=a[i+1];a[i+1]:=r; inc(i,2); end; for i:=1 to n do write(a[i],' '); readkey;end.
Задача 3.program z3; uses crt; var i,n,r,max,min,imax,imin:integer; a:array[1..10000] of integer;begin clrscr; randomize; write('число элементов n= '); readln(n); for i:=1 to n do begin a[i]:=random(45)-22; write(a[i],' '); end; min:=a[1]; max:=a[1]; for i:=1 to n do begin if a[i]<=min then begin min:=a[i]; imin:=i; end; max:=a[i]; imax:=i; end; end; readkey;end.program z4; const N=10; type Mas=fray [1..N] of integer; var a: Mas; i: integer; S:integer;begin randomize; for i:=l to N do begin a[i]:=-100+random(201); write(a[i]:5) end; writeln;
S:=0; if A[i]>0 then S:=S+A[i]; writel readln end.program z5; uses crt; var i,k,,r:integer; a:array[1..10000] of integer;begin clrscr; randomize; write(' число элемен. п=');readln(n); for i:=1 to n do begin a[i]:=random(45)-22; write(a[i], ' ');{Проверяем на четность и считаем количество четных элементов.} if a[i] mod 2=0 then inc(k, 1); end; write('k= ',k); readkeyend.
Не нашли ответ?
Похожие вопросы