1) напишите программу формирования массива размером 5х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением. выведите на экран исходный и измененн...
1) напишите программу формирования массива размером 5х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением. выведите на экран исходный и измененный массивы
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел
Ответ(ы) на вопрос:
1)
var a:array[1..5,1..5] of integer;
i,j,max:integer;
begin
randomize;
max:=0;
for i:=1 to 5 do
for j:=1 to 5 do begin
a[i,j]:=random(100);
if a[i,j]>max then max:=a[i,j];
end;
for i:=1 to 5 do begin
writeln;
for j:=1 to 5 do
write(a[i,j],' ');
end;
writeln;
writeln;
writeln;
for i:=1 to 5 do
for j:=1 to 5 do
if j=5 then a[i,j]:=max;
for i:=1 to 5 do begin
writeln;
for j:=1 to 5 do
write(a[i,j],' ');
end;
end.
2-ую лень. Дико извиняюсь.
Не нашли ответ?
Похожие вопросы