1) Составьте программу вычисления произведения чисел от 1 до 10 (1*2*3*..*) 2)Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10 3)Составьте программу, которая находит ...
1) Составьте программу вычисления произведения чисел от 1 до 10 (1*2*3*..*) 2)Составьте программу, которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10
3)Составьте программу, которая находит сумму квадратов чисел от 1 до 10
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=Range(1,10);
Writeln(s.Aggregate(1,(p,q)->p*q));
Writeln('S=',s.Where(k->k.IsEven).Sum,', П=',
s.Where(k->k.IsOdd).Aggregate(1,(p,q)->p*q));
Writeln('S2=',s.Select(k->k*k).Sum)
end.
Результат
3628800
S=30, П=945
S2=385
Не нашли ответ?
Похожие вопросы