1)Дан вектор {zi},i=1,...,50.составьте программу ввода значений и вычисления длины этого вектора по следующей формуле: L=корень квадратный z1 в кв.+z2 в кв.+...z50 в кв. 2)Даны значения массива {ai}, i=0,...,10 и переменной х. ...
1)Дан вектор {zi},i=1,...,50.составьте программу ввода значений и вычисления длины этого вектора по следующей формуле: L=корень квадратный z1 в кв.+z2 в кв.+...z50 в кв.
2)Даны значения массива {ai}, i=0,...,10 и переменной х. составьте программу вычисления алгебраического многочлена 10-й степени по формуле герона:
а10х в 10 степени+а9хв 10 степени+...+а1х+а0=((...(а10х+а9)х+а8)х+...+а1)х+а0.
срочно!!!
Спасибо
Ответ(ы) на вопрос:
Гость
1)program vector; var z:array[1..50]of real; l,s:real; i:integer; begin for i:=1 to 50 do readln(z[i]); s:=0; for i:=1 to 50 do begin z[i]:=sqr(z[i]); s:=s+z[i]; end; l:=sqrt(s); writeln(l); end.
Не нашли ответ?
Похожие вопросы