1)Написать программу используя процедуру которая сортирует элементы целочисленного массива в [1..n],n меньше или равно 25 по убыванию 2)Дни недели пронумерованы след образом:1 пон....7воскрес.Написать программу которая использу...
1)Написать программу используя процедуру которая сортирует элементы целочисленного массива в [1..n],n<или равно 25 по убыванию
2)Дни недели пронумерованы след образом:1 пон....7воскрес.Написать программу которая использует процедуру которая по известному номеру дня недели вернет его значение .
3)Написать программу которая использует функцию которая возвращает кол-во всех символов кроме пробелов содержащихся в строке символов
(Решите все на базе PASCAL 7.0)
Ответ(ы) на вопрос:
Гость
//1)
Type
ty=array[1..25] of integer;
Var
n,i:integer;
ar:ty;
procedure sortbutmeh(var ar:ty;n:integer);
Var
i,j,c:integer;
begin
for i:=1 to n-1 do
for j:=i+1 to n do
if ar[i]0 do
delete(s,pos(' ',s),1);
lengthbutmeh:=length(s);
end;
begin
readln(s);
writeln(lengthbutmeh(s));
end.
Не нашли ответ?
Похожие вопросы