1.Написать программу , которая вычисляет произведение цифр к-значного числа. 2. пусть элементами равносторон.треугольника являются : сторона a, высота h, площадь S, вписанная окружность r, описанная окружность R. составить прог...
1.Написать программу , которая вычисляет произведение цифр к-значного числа. 2. пусть элементами равносторон.треугольника являются : сторона a, высота h, площадь S, вписанная окружность r, описанная окружность R. составить программу , которая по заданному номеру и значению элемента , вычисляла бы значения всех остальных элементов
Ответ(ы) на вопрос:
Решу только первую задачу.
const k=?; {Вместо "?" подставить любое значение k}
Var x,i,s:integer;
Begin
write('x=');
readln(x);
s:=1;
for i:=1 to k do
begin
s:=s*(x mod 10);
x:=x div 10;
end;
writeln('s=',s);
End.
Не нашли ответ?
Похожие вопросы