1)Написать программу, вычисляющую сумму и среднее арифметическоепоследовательности положительных чисел, которые вводятся с клавиатуры.вид экрана:Введите числа. Для завершения последовательности нажмите ноль.45 23 15 0введен...
1)Написать программу, вычисляющую сумму и среднее арифметическоепоследовательности положительных чисел, которые вводятся с клавиатуры.вид экрана:Введите числа. Для завершения последовательности нажмите ноль.45 23 15 0
введено чисел:3
сумма чисел:83
Среднее арифметическое:27.67
2)аписать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положи¬тельных чисел (длина последовательности не ограничена) . (Цикл Whil или Repeat)
Определение максимального числа последовательности
положительных чисел.
Вводите после стрелки числа. Для завершения ввода введите ноль.
-> 56
-> 75
-> 43
-> О
Максимальное число: 75.
Ответ(ы) на вопрос:
uses crt;
var A, B:real;
begin
writeln('45, 23, 15');
writeln('Сумма чисел:3');
A:=45+23+15; B:=45+23+15/3;
writeln('Сумма чисел=',A); write('Среднее арифметическое=',B);
end.
uses crt;
var a,b,c,k:integer;
begin
a:=0; b:=0; k:=1;
repeatread(c);
k:=c; a:=a+c; inc(b);
until k=0;
write(a,' ',a/(b-1));
end.
Не нашли ответ?
Похожие вопросы