1.Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ..532. 2.-х- 3.Написать программу, которая вводит с клавиатуры число от 0 до 999999 (и
1.Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ..532. 2.-х- 3.Написать программу, которая вводит с клавиатуры число от 0 до 999999 (и спользовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа.
4.Составить алгоритм и программу сортировки массива символов латинского алфавита.
5.Составить алгоритм и программу сортировки массива по убыванию методом пузырьков с перемещнием минимального элемента.
---
хотя бы с одним помогите
Ответ(ы) на вопрос:
Гость
3. pascal var s, a: integer; g:longint; begin s:=0; readln(g); while g > 0 do begin a:=g mod 10; g:=g div 10; s:=s+a; end; writeln(s) end.
Не нашли ответ?
Похожие вопросы