1)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком. 2)Составьте программу на языке Pascal, в кот...
1)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
2)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.
Ответ(ы) на вопрос:
1)
var
mas: array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 10 do begin
if mas[i]<0 then
write(abs(mas[i]),' ')
else
write(-mas[i],' ');
end;
end.
2)
var
mas: array [1..10] of real;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 5 do
write(mas[i]*2,' ');
for i:=6 to 10 do
write(mas[i]/2,' ');
end.
Не нашли ответ?
Похожие вопросы