2. Дан числовой массив А, состоящий из п натуральных чисел. Определите количество элементов массива, которые больше заданного числа. (3 балла)
2. Дан числовой массив А, состоящий из п натуральных чисел. Определите количество элементов массива, которые больше заданного числа. (3 балла)
Ответ(ы) на вопрос:
Program Free Pascal 2.6.0; Uses crt; const n = 5; // например 5 var A:array [1..n] of integer; i,col:integer; begin clrscr; col:=0; // Кол-во элементов больших заданного изначально = 0 for i:=1 to n do begin read(A[i]); // Заполняем массив произвольными числами if (A[i]>n) then col:=col+1; // Если введенное число больше задонного (>5), то кол+1 end; writeln; writeln('Кол-во элементов больших заданного: ',col); readkey; end.
Не нашли ответ?
Похожие вопросы