2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному.

2) Заполнить массив А случайными целыми числами разных знаков. Составить программу вывода на экран номеров элементов массива, равных максимальному.
Гость
Ответ(ы) на вопрос:
Гость
var mas: array[-1000..1000] of integer;   i, max, n: integer; begin   {ввод количества элементов массива}   readln(n);   {ввод массива и его вывод на экран}   randomize;   for i := 1 to n do    begin     mas[i] := 50 - random(100) - 1;     write(mas[i]:5);     if (i mod 10 = 0) then writeln;   end;   {поиск максимума}   max := mas[1];   for i := 2 to n do       if (mas[i] > max) then max := mas[i];   {нахождение номеров элементов массива}  writeln;   for i:=1 to n do if (mas[i] = max) then write(i,'  ');  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы