60 Балов Написать программу решения квадратного уравнения: Ax²+Bx+C=0
60 Балов
Написать программу решения квадратного уравнения:
Ax²+Bx+C=0
Ответ(ы) на вопрос:
var
a,b,c,D,x1,x2:double;
begin
Write('Введите коэффициенты квадратного уравнения А В С: ');
Read(a,b,c);
if a=0 then
Writeln('А не может равняться нулю: уравнение не будет квадратным')
else begin
D:=sqr(b)-4*a*c;
if D<0 then Writeln('Нет корней')
else
if D=0 then Writeln('x=',-b/(2*a))
else begin
D:=sqrt(D);
x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a);
Writeln('x1=',x1,', x2=',x2)
end
end
end.
Тестовое решение:
Введите коэффициенты квадратного уравнения А В С: 2 -5 3
x1=1, x2=1.5
var a,b,c,D,x1,x2:double; begin Write('Введите коэффициенты квадратного уравнения А В С: '); Read(a,b,c); if a=0 then Writeln('А не может равняться нулю: уравнение не будет квадратным') else begin D:=sqr(b)-4*a*c; if D<0 then Writeln('Нет корней') else if D=0 then Writeln('x=',-b/(2*a)) else begin D:=sqrt(D); x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a); Writeln('x1=',x1,', x2=',x2) end end end. Тестовое решение: Введите коэффициенты квадратного уравнения А В С: 2 -5 3 x1=1, x2=1.5 ответ у модератора совершенно верен.
Не нашли ответ?
Похожие вопросы