Cоставить схему алгоритма и написать программу вычисления таблицы значений функц
Cоставить схему алгоритма и написать программу вычисления таблицы значений функции f(x) на промежутке x [xн; xк] с шагом h.
Ответ(ы) на вопрос:
Преобразуем формулу в рекуррентную.
var
i,k:integer;
x,s,a:real;
begin
x:=-2;
while x<=3 do begin
a:=sqr(2/(x+2.5))*2;
s:=a;
for k:=2 to 5 do begin
a:=-a*(2/(x+2.5))*(k+1);
s:=s+a
end;
Writeln('x=',x:4:1,', f(x)=',s);
x:=x+0.5
end
end.
Результаты
x=-2.0, f(x)=2832032
x=-1.5, f(x)=42584
x=-1.0, f(x)=3604.93827160494
x=-0.5, f(x)=620
x= 0.0, f(x)=157.46048
x= 0.5, f(x)=51.2592592592593
x= 1.0, f(x)=19.8483285025797
x= 1.5, f(x)=8.75
x= 2.0, f(x)=4.27306135582313
x= 2.5, f(x)=2.27072
x= 3.0, f(x)=1.29731462817256
Не нашли ответ?
Похожие вопросы