Дан массив( а) из n элементов , нужно удалить 1ый встретившиеся нулевой элемент из массива (помогите написать программу)

Дан массив( а) из n элементов , нужно удалить 1ый встретившиеся нулевой элемент из массива (помогите написать программу)
Гость
Ответ(ы) на вопрос:
Гость
const   n=13; var   a:array[1..n] of integer;   i,k,t:integer; begin   Randomize;   Writeln('Исходный массив');   for i:=1 to n do     begin     a[i]:=Random(21)-10;     Write(a[i],' ')     end;   Writeln;   { начало собственно программы }   i:=1; k:=0;   while (i<=n) and (k=0) do     begin     if a[i]=0 then k:=i;     i:=i+1     end;   if k>0 then     begin     for i:=k to n-1 do a[i]:=a[i+1];     Writeln('Массив-результат');     for i:=1 to n-1 do Write(a[i],' ');     Writeln     end   else     Writeln('В массиве нет нулевых элементов') end. Контрольное решение Исходный массив 6 -6 10 -9 6 9 0 10 6 0 -10 -3 6 Массив-результат 6 -6 10 -9 6 9 10 6 0 -10 -3 6
Не нашли ответ?
Ответить на вопрос
Похожие вопросы