Дан массив a из n целых чисел. Требуется посчитать количество положительных элемен
Дан массив a из n целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов.
Формат входных данных
На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.
Формат выходных данных
Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.
Примеры
входные данные:
3
-2 0 5
выходные данные
1 1
Ответ(ы) на вопрос:
//Dev-C++ 5.11 (C)
#include <stdio.h>
int main(void)
{int arr[100],n,pos,neg;
scanf("%d",&n);
pos=0;
neg=0;
for(int i=0;i<n;i++)
{scanf("%d",&arr[i]);
if(arr[i]>0)
pos++;
if(arr[i]<0)
neg++;} printf("%d %d",pos,neg); return 0;}
scanf("%d",&n);
pos=0;
neg=0;
for(int i=0;i<n;i++)
{scanf("%d",&arr[i]);
if(arr[i]>0)
pos++;
if(arr[i]<0)
neg++;} printf("%d %d",pos,neg); return 0;}
Не нашли ответ?
Похожие вопросы