Дан массив a из n целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов. Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — чи...
Дан массив a из n целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов.
Формат входных данных
На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.
Формат выходных данных
Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.
Примеры
входные данные:
3
-2 0 5
выходные данные
1 1
Ответ(ы) на вопрос:
//Dev-C++ 5.11 (C)
#include
int main(void)
{int arr[100],n,pos,neg;
scanf("%d",&n);
pos=0;
neg=0;
for(int i=0;i0)
pos++;
if(arr[i]<0)
neg++;}
printf("%d %d",pos,neg);
return 0;}
var
i, c, k, n: integer;
ar: array[1..10000]of integer;
begin
c := 0;
k := 0;
readln(n);
for i := 1 to n do
begin
read(ar[i]);
if (ar[i] > 0) then c := c + 1;
if (ar[i] < 0) then k := k + 1;
end;
write(c, ' ', k);
end.
Не нашли ответ?
Похожие вопросы