Дан массив из 10 элементов. составить программу, находящую среднее арифметическое положительных.
Дан массив из 10 элементов. составить программу, находящую среднее арифметическое положительных.
Ответ(ы) на вопрос:
program mass;
uses crt;
var massiv:array[1..10] of integer;
i,count:integer;
sra:real;
begin
for i:=0 to 10 do begin
readln(massiv[i]);
if massiv[i] > 0 then begin
count:= count+1;
sra:= sra + massiv[i];
end;
end;
sra:= sra/count;
writeln('Среднее арифметическое = ',sra);
end.
Не нашли ответ?
Похожие вопросы