Дан текстовый файл. Составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. Вставьте в конце каждой строки количество слов и записать в новом файле.
Дан текстовый файл. Составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. Вставьте в конце каждой строки количество слов и записать в новом файле.
Ответ(ы) на вопрос:
var s : string; finish,k,i : longint;begin assign(input,'input.txt'); reset(input); assign(output,'output.txt'); rewrite(output); finish:=0; while(finish=0) do { если finish будет <> 0 то программа перестанет читать текст} begin writeln('читать? если да, то 0 если нет, то 1'); readln(finish); k:=0; if finish=0 then begin readln(s); for i:=1 to length(s) do if s[i]=' ' then inc(k); end else exit; inc(k); writeln(k); end;end.
Не нашли ответ?
Похожие вопросы