Дана последовательность натуральных чисел,окончанием последовательности число 0. составить программу , котрая вычисляет сумму и среднее арифмитическое чисел кратных 3

Дана последовательность натуральных чисел,окончанием последовательности число 0. составить программу , котрая вычисляет сумму и среднее арифмитическое чисел кратных 3
Гость
Ответ(ы) на вопрос:
Гость
var x, s, n: integer; sr: real; begin repeat readln(x); if (x mod 3 = 0) and (x>0) then begin s:=s+x; n:=n+1; end; until x=0; sr:=s/n; writeln(sr); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы