.Дано число к (0 меньше к меньше 366) числу к=1 соответствует день 1 января . среда .Напишите программу которая опред. День который соотв.введеному числу к. Ребята,умоляю очень срочно помогите решить. Пожалуйста пожалуйста пож...

.Дано число к (0<к<366) числу к=1 соответствует день 1 января . среда .Напишите программу которая опред. День который соотв.введеному числу к. Ребята,умоляю очень срочно помогите решить. Пожалуйста пожалуйста пожалуйста очень прошу даю 30 баллов умоляю помогите
Гость
Ответ(ы) на вопрос:
Гость
var     k: integer; begin     writeln('Введите число');     readln(k);     case(k mod 7) of         1: writeln('Среда');         2: writeln('Четверг');         3: writeln('Пятница');         4: writeln('Суббота');         5: writeln('Воскресенье');         6: writeln('Понедельник');         0: writeln('Вторник');     end; end.
Гость
#include using namespace std; int main (){ setlocale(LC_ALL,"Rus"); int dp,N,S=7; cout<<"\n  День="; cin>>N; while(N>S){ N=N-7; }  dp=N;  switch(dp) {      case 1:        cout<<"\n  Среда"<
Не нашли ответ?
Ответить на вопрос
Похожие вопросы