Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3
Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3
Ответ(ы) на вопрос:
Гость
var
n,d:integer;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
Read(f,n);
Assign(f,'output.txt'); Rewrite(f);
d:=n mod 10;
while n>=10 do n:=n div 10;
if n>d then Writeln(f,'>')
else
if n=d then Writeln(f,'=') else Writeln(f,'<');
Close(f)
end.
TXT
Гость
var n, i: integer;
begin
i := 3;
while i <= n do
begin
write(i, ' ');
i := i + 10;
end;
end.
Не нашли ответ?
Похожие вопросы