Дано целое число X и натуральное число N. Составте алгоритм вычисления X^N. Напишите программу на Паскале.
Дано целое число X и натуральное число N. Составте алгоритм вычисления X^N. Напишите программу на Паскале.
Ответ(ы) на вопрос:
поправьте меня если ^ это не указатель стпени, но если это степень то вот очень просто: var a,x:extended; n,i:longint;
Begin
read(x);
read(n);
a:=1;
for i:=1 to n do
a:=a*x;
writeln(a:0:0);
end.
Не нашли ответ?
Похожие вопросы