Даны два натуральных числа. Выяснить в каком из них сумма цифрбольше.Написать программу в паскале абс,использую функцию.
Даны два натуральных числа. Выяснить в каком из них сумма цифр
больше.Написать программу в паскале абс,использую функцию.
Ответ(ы) на вопрос:
function summ (a : integer) : integer;
var
s : integer;
begin
s := 0;
while (a > 0) do
begin
s := s + a mod 10;
a := a div 10;
end;
summ := s;
end;
var
a, b : integer;
begin
read (a, b);
a := summ (a);
b := summ (b);
if a > b then write ('in 1') else if b > a then write ('in 2') else write ('eq');
end.
Не нашли ответ?
Похожие вопросы