Даны натуральные числа А и В (В меньше А). написать программу , выводящую на экран сумму натуральных чисел от В до А, включая В и А.
Даны натуральные числа А и В (В<А). написать программу , выводящую на экран сумму натуральных чисел от В до А, включая В и А.
Ответ(ы) на вопрос:
uses crt;const h=10;var a,b,S: integer;
begin write('A= '); readln(a); write('B= '); readln(b); S:=0; while b<>a+1 do begin S:=S+b; inc(b); end; writeln('Сумма - ',S);end.
var a,b,sum:integer;
begin
readln(a,b);
for b:=b+1 to a do
sum:=sum+b;
writeln(sum);
end.
Не нашли ответ?
Похожие вопросы