Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, с чётными порядковыми номерами и нечётными значениями.

Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, с чётными порядковыми номерами и нечётными значениями.
Гость
Ответ(ы) на вопрос:
Гость
var i,n,k:integer; a:array[1..100] of integer; begin readln(n); for i:=1 to n do read(a[i]); for i:=1 to n do if odd(a[i]) and not odd(i) then inc(k); writeln('Кол-во элементов с четн.номерами и нечетн.значениями: ',k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы