Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y. 

Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y. 
Гость
Ответ(ы) на вопрос:
Гость
program raznost_xy; var x, y:integer; begin write ('Введите число х = '); readln (x); write ('Введите число у = '); readln (y); if (x>0) and (y>0) then   begin     if abs(x)>abs(y) then write ('x-y > 0');     if abs(x)=abs(y) then write ('x-y = 0');     if abs(x)abs(y) then write ('x-y < 0');     if abs(x)=abs(y) then write ('x-y = 0');     if abs(x) 0');   end; if (x=0) and (y=0) then write ('x-y = 0'); if (x>0) and (y<0) then write ('x-y > 0'); if (x<0) and (y>0) then write ('x-y < 0'); if (x=0) and (y>0) then write ('x-y < 0'); if (x=0) and (y<0) then write ('x-y > 0'); if (x>0) and (y=0) then write ('x-y > 0'); if (x<0) and (y=0) then write ('x-y < 0'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы