Двухмерный массив. Составить программу: вычислить произведение и количество отрицательных элементов матрицы В[4,4] под главной диагональю.
Двухмерный массив.
Составить программу: вычислить произведение и количество отрицательных элементов матрицы В[4,4] под главной диагональю.
Ответ(ы) на вопрос:
Гость
double[,]B=new double[4,4]; double proizv=1; double count=0; for(int i=0;i<4;i++) for(int j=0;j<4;j++) Console.Writeline(B[i,j]);//ввод элементов for(int j=0;j<4;j++) for(int i=0;i<4;i++) {if(B[i,j]<0) {proizv*=B[i,j]; count++; }
Не нашли ответ?
Похожие вопросы