ФИЗ МААААААТ ПОМОГИТЕ ПЛЕАЗ Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
ФИЗ МААААААТ ПОМОГИТЕ ПЛЕАЗ Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответ(ы) на вопрос:
на си программа
void main( void )
int i, a ,b ,c, flag;
scanf("%i",i);
a = i%10;
b = (i/10)%10;
c = (i/100)%10;
if( a = b )
flag = 1;
if( a = c )
flag = 1;
if( b = c )
flag = 1;
if( flag = 1)
printf(" Есть" );
else
printf(" нет" );
}
Не нашли ответ?
Похожие вопросы