Индивидуальное зачетное задание Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в Паскале работают с ра...
Индивидуальное зачетное задание
Напишите программу, запрашивающую у пользователя время и сообщающую угол поворота минутной и часовой стрелки в градусах и радианах (помните, что тригонометрические функции в Паскале работают с радианами)
Ответ(ы) на вопрос:
var
n,m:integer;
r1,r2:real;
begin
writeln('Введите количество часов: ');
readln(n);
writeln('Введите количество минут: ');
readln(m);
n:=n mod 12;
r2:=m/60*360;
r1:=(n*360+r2)/12;
writeln('Угол поворота часовой стрелки ',r1,' градусов или ',r1/180*Pi,' радиан');
writeln('Угол поворота минутной стрелки ',r2,' градусов или ',r2/180*Pi,' радиан');
end.
Не нашли ответ?
Похожие вопросы