Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр.Я написал первую часть программы (без в...
Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр.
Я написал первую часть программы (без вывода суммы цифр) :
program sg3;
uses crt;
var i,a,k: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then k:=k+1;
if k=0 then write('Простое')
else writeln('Составное');
readln;
end.
Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль
Ответ(ы) на вопрос:
program sg3;
uses crt;
var i,a,k, sum: integer;
begin
clrscr;
write('Введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then
k:=k+1;
if k=0 then
write('Простое')
else
writeln('Составное');
while (a<>0) do
begin
sum:=sum+(a mod 10);
a:=a div 10;
end;
write('Сумма цифр= ',sum);
end.
Не нашли ответ?
Похожие вопросы