ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! ПОМОГИТЕ, ПОЖАЛУЙСТА! Написать программу которая удаляет все точки і запятые из строки s.
ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! ПОМОГИТЕ, ПОЖАЛУЙСТА! Написать программу которая удаляет все точки і запятые из строки s.
Ответ(ы) на вопрос:
Гость
Pasca
program eazy;
var s:string;
i:integer;
begin
writeln('Vvedite tekst');
readln(s);
for i:=length(s) downto 1 do
if (s[i]=' ') or(s[i]=',') or (s[i]='.') then
delete(s,i,1) ;
writeln(s);
end.
Гость
Решение для одного-двух разных удаляемых символов
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Replace('.','').Replace(',','');
s.Println
end.
Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять
Решение, когда разных удаляемых символов может быть много
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
s.Println
end.
Не нашли ответ?
Похожие вопросы