ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить лишние пробелы в строке s, оставив по одному пробелу между словами. Строку s, состоящую из слов, разделённых пробеламі, введите с клавиатуры.
ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! Составьте программу, которая позволяет удалить лишние пробелы в строке s, оставив по одному пробелу между словами. Строку s, состоящую из слов, разделённых пробеламі, введите с клавиатуры.
Ответ(ы) на вопрос:
var s: string;
begin
writeln('Введите строку:');
readln(s);
while pos(' ',s)>0 do delete (s,pos(' ',s),1);
writeln(s);
end.
Пример:
Введите строку:
Строку s введите с клавиатуры.
Строку s введите с клавиатуры.
Не нашли ответ?
Похожие вопросы