Массив А вводится с клавиатуры. Найти суммы чётных, количество отрицательных его элементов. Размер произвольный. Написать программу с одной функцией и процедурой . За ранее огромное спасибо

Массив А вводится с клавиатуры. Найти суммы чётных, количество отрицательных его элементов. Размер произвольный. Написать программу с одной функцией и процедурой . За ранее огромное спасибо
Гость
Ответ(ы) на вопрос:
Гость
const  n=10; type  ta=array[1..n] of integer; var ar:ta; k,s:integer; procedure reading(var ar:ta); var i:integer; begin; for i:=1 to n do readln(ar[i]); end; procedure Sum(ar:ta;var k:integer); var i:integer; begin; for i:=1 to n do if ar[i] mod 2=0 then k:=k+ar[i]; end; function Otr(ar:ta):integer; var i,s:integer; begin; for i:=1 to n do if ar[i]<0 then inc(s); Otr:=s; end; begin; reading(ar); Sum(ar,k); s:=Otr(ar); writeln('Sum:',k); write('Otr:',s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы