Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, являющихся двузначными числами. (2 задача)
Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, являющихся двузначными числами. (2 задача)
Ответ(ы) на вопрос:
Гость
program wk;
var mas:array [1..10] of integer;sr,k,i:integer;
begin
k:=0;
sr:=0;
for i:=1 to 10 do
begin
readln(mas[i]);
if (mas[i] div 10)<>0 then
begin
sr:=mas[i]+sr;
k:=k+1
end;
end;
writeln(sr/k)
end.
Не нашли ответ?
Похожие вопросы